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1	 INTRODUCTION

From Scan to CAD in no time
Bring physical parts into digital parametric CAD models with a reverse-engineering software that combines history-based CAD with 

3D scan data processing. Geomagic® Design X™ is the industry’s most comprehensive reverse engineering software, combines histo-

ry-based CAD with 3D scan data processing so you can create feature-based, editable solid models compatible with your existing 

CAD software.

What Can You Do with Geomagic Design X?
Geomagic Design X converts 3D scan data into high-quality, feature-based CAD models. The software combines automatic and 

guided solid model extraction in a unique way while being incredibly accurate.

Scan virtually anything and create producible designs.

	y Rebuild CAD data for broken tools and molds.

	y Recreate lost CAD data for parts and molds.

	y Design custom products.

	y Convert physical parts into CAD for new product designs.

	y Make existing parts fit with new parts.

INTRODUCING GEOMAGIC® DESIGN X™ 
Version: 2024.3.1
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2	 INSTALLATION

System Requirements
For the latest system requirements information and to learn about specific qualified system configurations, go to the System 

Requirements page in the Geomagic Support Center. Some users have had success running system configurations that deviate from 

the supported listed on our website. In such cases, these configurations are not officially supported by Oqton.

Additionally, we test a variety of hardware platforms in combination with the graphics subsystems. While we make every attempt to 

be as thorough as possible, hardware manufacturers change their products frequently and may be shipping newer products or have 

discontinued active support for others. Check the support section of the website for the latest system requirement information and 

specific qualified systems.

Download and Install software
You can download and install the software from https://softwaresupport.oqton.com/s/article/GeomagicDesignX.

In addition, automatic software updates are available if you set the Update Product Automatically option to True in Preferences and 

a valid maintenance code is activated, and your computer is connected to the Internet. The application will check if a newer version is 

available and will download it automatically for installation.

You can also manually check if a newer version is available by going to Help > Check For Update.

Activate License
Geomagic Design X requires license activation to run the application on your PC. You can choose to use a trial license for a 15-day 

period or activate a permanent license.

After you start your application, the License Manager window opens. The License Manager allows you to activate and use the 

Geomagic Design X software.

NOTE: When the License Manager is launched, you can click the Help  button found at the top right corner of the window to 
read the CimLM Licensing Guide. 

https://softwaresupport.oqton.com/s/article/GeomagicDesignX
https://softwaresupport.oqton.com/s/article/GeomagicDesignX
https://softwaresupport.oqton.com/s/article/GeomagicDesignX
https://softwaresupport.oqton.com/s/article/CimLM-Licensing-Support
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3	 NEW FEATURES AND ENHANCEMENTS

Instructions for using legacy scanner plug-ins are available on the Oqton Software Support Community at the following link: 

https://softwaresupport.oqton.com/s/article/Enabling-Legacy-Scanner-Plugins-for-Design-X-Control-X-2024-1

Additionally, instructions for PMT Probe Plug-Ins can be found on the Oqton Software Support Community at the following 

link: https://softwaresupport.oqton.com/s/article/PMT-Scanner-Plugin

Important Notice

Version 2024.3.1

Release Date: November, 2024

DXF File Import and Export for Go and Plus Editions

Support for importing and exporting DXF (AutoCAD DXF) file format has been added to the Geomagic Design X Go and Plus 

editions.

Note: This topic includes features exclusive to the Geomagic Design X Plus or Pro licenses, marked with "Plus " or "Pro 
" labels for each identification.

Geomagic Design X Editions
Geomagic Design X now offers several editions, each designed to meet specific design needs. Each edition builds on the previous one 

by adding unique features and enhanced workflow capabilities.

	y Geomagic Design X Go  - A comprehensive solution for starting your reverse engineering projects.

	y Geomagic Design X Plus  - Enhanced tools for optimizing your scan-to-CAD workflows.

	y Geomagic Design X Pro  - Our most advanced reverse engineering solution, offering everything needed to convert any 

scan data into parametric CAD.

For more information on the features available in each edition, see Working with Geomagic Design X Editions in the Geomagic 

Design X Help, or visit the Geomagic Design X webpage at https://oqton.com/geomagic-designx. For assistance, contact our 

technical support team at https://softwaresupport.oqton.com/s/article/Contact-Us, email techsupport@oqton.com, or reach out to 

your regional sales manager.

Version 2024.3.0

Release Date: September, 2024

https://softwaresupport.oqton.com/s/article/Enabling-Legacy-Scanner-Plugins-for-Design-X-Control-X-2024-1
https://softwaresupport.oqton.com/s/article/PMT-Scanner-Plugin
https://oqton.com/geomagic-designx
https://softwaresupport.oqton.com/s/article/Contact-Us
mailto:techsupport%40oqton.com?subject=
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Auto Sketch Improvements 
Improvements to Auto Sketch enhance sketching accuracy and better align with user expectations.

New "Equal Constraints" Option for Enhanced Sketch Control

A new "Equal Constraints" option has been introduced in Auto Sketch. This option enables you to quickly apply equal length and 

equal radius constraints to circle, slots, rectangles, and arcs based on your specified search criteria. It streamlines the process of 

enforcing consistent constraints on sketches with similar geometry.

Extracting Circles with Equal Constraints Extracting Slots with Equal Constraints

New "Major Radius" and "Minor Radius" Options for 
Ellipses

The "Major Radius" and "Minor Radius" options have been added for the ellipse sketch 

entity type. These options provide more precise search control for ellipses by allowing 

searches based on their major and minor radii within section polylines.
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Improved Precision in Extracting Specific Entities

The algorithm for extracting user-specific sketch entities (such as circles, slots, rectangles, ellipses, lines, and arcs) from selected 

section polylines has been enhanced. The fitting criteria in Auto Sketch have been refined to produce accurate, non-overlapping 

sketches, eliminating unnecessary ones. The updated algorithm now intelligently determines whether segments of the selected 

polyline can be merged into a single desired sketch entity.

Extracting Circles in Geomagic Design X 2024.3.0 Extracting Circles in Geomagic Design X 2024.2.0

Extracting Slots in Geomagic Design X 2024.3.0 Extracting Slots in Geomagic Design X 2024.2.0

Note: These algorithm enhancements apply to the Extraction Wizard and the Revolution Wizard, both of which utilize the Auto 
Sketching process.
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Fill Holes Improvements
Improvements to Fill Holes make the process more intuitive and user-friendly. Additionally, the results for non-manifold hole filling 

have been significantly enhanced.

New Bridging Method

The Fill Holes command now supports multi-edge bridging with an enhanced Bridge method. This allows you to connect multiple 

edges to multiple other edges. This method enhances hole filling by bridging edges that are relatively distant from each other while 

preserving the curvature of adjacent poly-faces. Additionally, you no longer need to hold down the left mouse button to draw the 

bridge.

Enhanced Fill Holes Command with Fill Gulf Method

The Fill Holes command now allows you to choose a specific portion of a hole to fill from either side using the Fill Gulf method. This 

enhancement saves time by reducing the need for repetitive operations when working with complex holes.
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Display of Filled Holes

When previewing fill results after filling holes in a mesh, only the boundaries of the filled areas are highlighted for intuitive 

identification. This enables easy comparison of how smoothly the holes have been filled in connection with the neighboring poly-

faces.

Hole Filling in Geomagic Design X 2024.3.0 Hole Filling in Geomagic Design X 2024.2.0

Display of Hole Count

The Fill Holes command now displays the number of holes in 

the target mesh, allowing for intuitive identification. The count 

updates in real-time as holes are filled.

Improved Results and Robustness

Numerous issues with the Fill Holes have been resolved to enhance hole filling results and overall robustness. For more details on the 

resolved issues, please see the Fixed Bugs list.



Oqton, Inc. 8

Improvements to Solid and 
Surface Primitives
The Solid and Surface Primitives commands have been improved to 

support poly-vertices and poly-faces as target entities when extracting 

specific shapes.

Fitting Deviation and Tolerance Color Display when 
Previewing Reference Geometry
New "Show Fitting Deviation on Preview" and "Show Tolerance Color on Preview" options have been added to the Reference Plane 

and Reference Vector commands, allowing you to check fitting deviation and tolerance colors using a color map while reviewing 

geometry fitting results.

Display of Selected Entity Count
All commands now display the number of selected entities in the target or tool, 

allowing for easier identification. The count updates in real-time as selections are 

made.
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Retaining Properties After Cut and Merge Operations 
Improvements have been made to retain the properties of resulting bodies when performing Cut or Merge operations on existing 

bodies to create solid or surface bodies. The resulting body now retains properties such as custom name, material color, and visibility 

settings of the target body. If the target body belongs to a body group, the resulting body will remain within that group.

Before Merging in Geomagic Design X 2024.3.0 After Merging in Geomagic Design X 2024.3.0

Before Merging in Geomagic Design X 2024.2.0 After Merging in Geomagic Design X 2024.2.0

Performance Enhancements for Average Meshes 

The Average Mesh command has been optimized to address performance issues. With improvements to the computational 

algorithm and the implementation of parallel processing, performance has been increased by over 90% compared to the previous 

version.

Improved Execution Performance

Execution performance has been significantly enhanced by optimizing and reducing unnecessary pre-processing tasks when running 

applications.

Performance Improvements
Performance has been enhanced to provide a smoother and more efficient working experience.
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LiveTransfer To Latest CAD Software Versions
Geomagic Design X now supports Creo 10, Creo 11, and Inventor 2025. As a result, the following versions of CAD software are 

currently available in LiveTransfer:

	y SOLIDWORKS 2006~2024

	y NX 8~1953 series

	y Creo up to 11.0

	y AutoCAD 2010~2011

	y Inventor 2010~2025

Note: LiveTransfer also supports older versions of CAD software, but please be aware that CAD software versions prior to the 
previous three releases have not been tested and we cannot guarantee LiveTransfer functionality for these versions.

LiDAR File Import
Added support for importing LAS and LAZ files from LiDAR 3D scanners.

File I/O
Micrometer Import Unit Support

The micrometer unit ("μm") is now supported for handling small models accurately. You can select micrometers as the default 

measurement unit in Preferences or when importing scan data with mismatched units.

Unit Selection in Preferences Confirming Input (Scanner) Unit



Oqton, Inc. 11

4	 BUG FIXES

Note: This topic includes features exclusive to the Geomagic Design X Plus or Pro licenses, marked with "Plus " or "Pro 
" labels for each identification.

Version 2024.3.2

Release Date: December, 2024

Version 2024.3.1

Release Date: November, 2024

Geomagic Design X Essentials

	y GDX-23780:
Surface tools such as Extrude, Revolve, Loft, and Sweep, which were available in Geomagic Design X Essentials, 

were missing in the 2024.3.1 release of Geomagic Design X. These tools did not appear in either the Ribbon Bar 

or the Menu.

Common
	y GDX-23591, 

GDX-23432:

After creating a reference plane using the "Draw Line" method in the Add Plane command, the cursor remained 

in pencil mode, and subsequent selections could not be made.

	y GDX-23454:
A graphical error occurred when selecting poly-faces in the Add Plane command with "Show Fitting Deviation 

On Preview" enabled. After clicking OK to create a reference plane, subsequent selections could not be made 

within the same command while the "Show Fitting Deviation On Preview" option was enabled.

File I/O
	y GDX-23580, 

GDX-23584: Leica .PTS export was not available in the export dialog despite being listed as a supported format.

	y GDX-23486:
In Design X 2024.3, the export unit for STEP files was set to centimeters instead of millimeters, unlike in version 

2024.2 and earlier.



Oqton, Inc. 12

Common
	y GDX-22989:

 
After using the Sew command in the Insert > Surface or the Mirror command in the Insert > Modeling Feature, 

undoing and redoing copied the body to the model tree.

	y GDX-22861: The default name for a new tab in the Ribbon was not displayed as 'New Tab.'

	y GDX-22784:
 

After using the Sew command in the Insert > Surface or the Mirror command in the Insert > Modeling Feature, 

the custom body name and material were changed.

	y GDX-22754, 

GDX-22716:
An invalid template path appeared in Preferences for some users.

Auto-Sketch
	y GDX-22690:

The application crashed intermittently during Auto Sketch operations.

	y GDX-21127: When extracting specific sketch entities from selected segments of section polylines, the desired entity type was 

not created if the selection included multiple geometry types.

Mesh Tools
	y GDX-22692: Mesh information was not updated in the tree after data editing.

	y GDX-21799: A strange texture appeared after filling a hole.

	y GDX-20549: An unnecessary or unclear message was displayed after filling holes.

	y GDX-18300: Selection or parameters were invalid in "Fill Gulf" with "Tangent Curvature."

	y GDX-17067: Poor mesh results were produced when using "Fill Gulf" with "Flat Curvature."

	y GDX-16044: Fill Holes results were inconsistent in some cases.

	y GDX-14974: The Fill Holes tool did not apply to textures.

	y GDX-9981: "Fill Gulf" with "Tangent Curvature" failed to fill holes in some cases.

	y GDX-9716: Boundary regions changed unexpectedly when filling holes.

	y GDX-9628: Selection disappeared when deleting a poly-face.

	y GDX-9340: The application crashed when running Mesh tools on a textured file.

	y GDX-7426: The Fill Holes operation did not function normally.

	y GDX-6772: An adjacent hole was also filled when attempting to fill a small hole.

Extrusion Wizard
	y GDX-22948: When performing "Solid Cut" on an existing solid body using a sketch profile with multiple loops in the Extrusion 

Wizard, the bottom of the extrusion was not created as expected.

Hardware Interface
	y GDX-21692: There were connection issues with Scanviewer 6.3.4.9.

Version 2024.3.0

Release Date: September, 2024
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File I/O
	y GDX-21558: ASCII Converter failed to read RGB information depending on the file's columns.

	y GDX-21549: The CSV option was missing in the Import dialog.

	y GDX-21223:
Incorrect color was displayed in Geomagic Design X when importing CSV formatted point cloud data with the 

"Use Convert ASCII" option.

Localization
	y GDX-22633, 

GDX-22302, 

GDX-22301, 

GDX-22835, 

GDX-22268:

There were translation and layout issues in the multilingual user interface.

	y GDX-21343: Untranslated words were found in the multilingual versions.

Documentation
	y GDX-22723: The Help file lacked descriptions of how the "Geometry Capture Accuracy" option affects the addition of 

constraints in the Auto Sketch command.
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