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Geomagic® Control X™ is a comprehensive metrology software platform that delivers the industry’s most powerful tools within 

straightforward workflows. With Geomagic Control X quality managers are enabled with revolutionary ease-of-use, intuitive, 

comprehensive controls and traceable, repeatable workflows for the quality measurement process. Its fast, precise, information-rich 

reporting and analysis enable significant productivity and quality gains in any manufacturing workflow.

Ensure Quality Everywhere
Bring the power of 3D scan-based inspection to more people in more places with industry-leading 3D metrology software that makes 
it easy to capture and interpret scan data.

What Can You Do with Geomagic Control X?
Geomagic Control X includes features to help you ensure quality for each stage of your manufacturing workflow including designing, 

manufacturing, inspecting, and maintaining.

Design
	y Design for 

manufacturability

	y Find and fix problems

Manufacture
	y Identify and resolve 

manufacturing and 

assembly issues

	y Eliminate costly scrap and 

rework

Inspect
	y Solve your toughest 

measurement problems

	y Improve quality 

documentation

	y Reduce quality control 

bottlenecks

Maintain
	y Assess damage, 

deformation, or 

wear accurately and 

consistently

	y Predict part failure before 

it happens

1	 INTRODUCTION

INTRODUCING GEOMAGIC® CONTROL X™
Version: 2025.0.0
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2	 INSTALLATION

System Requirements
For the latest system requirements information and to learn about specific qualified system configurations, go to the System 

Requirements page in the Geomagic Support Center. Some users have had success running system configurations that deviate from 

the supported listed on our website. In such cases, these configurations are not officially supported by Oqton.

Additionally, we test a variety of hardware platforms in combination with the graphics subsystems. While we make every attempt to 

be as thorough as possible, hardware manufacturers change their products frequently and may be shipping newer products or have 

discontinued active support for others. Check the support section of the website for the latest system requirement information and 

specific qualified systems.

Download and Install software
You can download and install the software from https://softwaresupport.oqton.com/s/article/Geomagic-Control-X.

To enable automatic updates, set the Check for Latest Version option to True in Preferences. The application will check for updates 

at launch and notify you if a newer version is available, guiding you through the download process. You can also manually check for 

updates by going to Help > Check For Latest Version.

Activate License
Geomagic Control X requires license activation to run the application on your PC. You can choose to use a trial license for a 15-day 

period or activate a permanent license.

After you start your application, the License Manager window opens. The License Manager allows you to activate and use the 

Geomagic Control X software.

NOTE: When you launch the License Manager, you can click the Help  button found at the top right corner of the window to 
read the CimLM Licensing Guide.

https://softwaresupport.oqton.com/s/article/Geomagic-Control-X
https://softwaresupport.oqton.com/s/article/Geomagic-Control-X
https://softwaresupport.oqton.com/s/article/Geomagic-Control-X
https://softwaresupport.oqton.com/s/article/CimLM-Licensing-Support
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3	 NEW FEATURES AND ENHANCEMENTS

Note: The  /  labels indicate features that are also available in Geomagic Control X Essentials and Geomagic Control X 
Essentials Connect software packages.

Automation with New Text Scripting
Introducing Text Scripting to expand automation capabilities in Geomagic Control X. This new tool enables the creation of custom 

workflows using Python APIs that correspond to Geomagic Control X commands, offering an efficient way to automate inspection 

processes.

Instructions for using legacy scanner plug-ins are available on the Oqton Software Support Community at the following link: 

https://softwaresupport.oqton.com/s/article/Enabling-Legacy-Scanner-Plugins-for-Design-X-Control-X-2024-1

Additionally, instructions for PMT Probe Plug-Ins can be found on the Oqton Software Support Community at the following 

link: https://softwaresupport.oqton.com/s/article/PMT-Scanner-Plugin

Important Notice

Key Features

	y Custom Workflows: Build workflows from scratch or use the 

script recording feature to capture scripts automatically while 

performing inspection tasks in Geomagic Control X.

	y User-Friendly IDE: The built-in integrated development environment (IDE) simplifies coding with features like IntelliSense for 

easier navigation and effective API usage.

https://softwaresupport.oqton.com/s/article/Enabling-Legacy-Scanner-Plugins-for-Design-X-Control-X-2024-1
https://softwaresupport.oqton.com/s/article/PMT-Scanner-Plugin
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New Circle Creation Methods 

Two new methods for Circle Constructed Geometry creation have been introduced:

	y Pick Cone & Cylinder: Create a circle from the 

intersection of a cone and a cylinder.

	y Intersect Cone at Diameter: Create a circle 

from a cone at a specified diameter.

New Probe Fitting Method For LiveInspect 
A new “Intersection with Cone and Cylinder” Probe Fitting Method for LiveInspect has been added to the Circle command. This 

method, also available in LiveGeometry, allows for the creation of circles based on the intersection of cones and cylinders.

Intersection with Cone and Cylinder Probe Fitting 

Method for LiveInspect in Circle command

Intersection with Cone and Cylinder in LiveGeometry
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New Circle Creation Method in Visual Script Editor
The Visual Script Editor now supports the “Intersect Cone at Diameter” and “Pick Cone & Cylinder” methods for Circle Constructed 

Geometry creation.

Circle (Intersect Cone At Diameter) Action Circle (Pick Cone & Cylinder) Action

New “Average Mesh” Command
The “Average Mesh” command, previously exclusive to Geomagic Design X, is now available in Geomagic Control X. This tool allows 

you to average multiple meshes and generate a new mesh or feature shape, which can serve as a standard part for inspection 

purposes.

Target Meshes to Be Averaged Averaged Mesh
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3D Compare Improvements 

Improvements to 3D Compare provide more accurate deviation results and improved comparison analysis.

Color Map Resolution

A new Color Map Resolution option allows control over the density of data points used to generate the color map. This provides 

flexibility in adjusting the level of detail and smoothness when analyzing deviations between Reference and Measured data.

This option also ensures that local average deviation results created with the Color Map Result Option align more closely with results 

from Whisker and Color Point Result Options, providing consistent deviation results across all options.

Low Color Map Resolution High Color Map Resolution

Statistics Display

The Properties for 3D Compare now display 

statistics calculated from raw scan points for 

Whisker and Color Points Result Options, as well 

as statistics calculated from averaged scan points 

based on the user-defined Color Map Resolution 

for the Color Map Result Option.

Comparison Statistics from Color Map 

Result while Low Color Map Resolution

Comparison Statistics from Color Point 

Result while Low Color Map Resolution
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Annotation for Twist 
Analysis
The Twist Analysis command now allows 

the creation, selection, and repositioning of 

annotations for local average deviation, offering 

more intuitive inspection and greater flexibility in 

customization.

Report Improvements 

The Report now includes “Pass/Fail” indicators in the data table, enhancing clarity and usability of inspection results.

 

Report Entity Templates for the following features have been updated to include “Pass/Fail” indicators by default:

	y Cross Section

	y Airfoil

	y Result Navigator

	y 3D GD&T

	y Cross Section Group

	y 3D GD&T Group

Additionally, the “Pass/Fail” indicators for inspection features with deviation 

results can now be customized in their templates using the Field Chooser.
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User Interface Improvements 

Display of Selected Entity Count

All commands now display the number of selected entities in the target or tool, 

allowing for easier identification. The count updates in real-time as selections are 

made.

Simplified the process for showing or hiding docking toolbars

The process for showing or hiding docking toolbars (e.g., Feature Tree, Properties Window) has been streamlined for ease of use.

In addition to using the context menu, you can now manage toolbars through two additional methods:

	y Menu: Go to Menu > View > Toolbar and select the toolbar you want to display from the submenu. 

	y Home Tab: In the Layout group on the Home tab, under the Toolbar menu, select the toolbar you want to show.

	y Context Menu: Right-click an empty space in the bottom toolbar and select the desired toolbar from the context menu.

Toobars in Menu Toolbars in Ribbon Bar
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File I/O 
Micrometer Unit Support

The micrometer unit ("μm") is now supported for handling small models accurately. You can select micrometers as the default 

measurement unit in Preferences or when importing scan data with mismatched units.

Unit Selection in Preferences Confirming Input (Scanner) Unit

LiDAR File Import

Added support for importing LAS and LAZ files from LiDAR 3D scanners.

Simulated CMM for Geomagic Control X Essentials 
Editions 
The Simulated CMM Point command is now available in both Geomagic Control X Essentials and Geomagic Control X Essentials 
Connect editions.

Miscellaneous Enhancements
Faster Software Startup Process 

Execution performance has been significantly improved by optimizing and reducing unnecessary pre-processing tasks, which 

previously affected only certain regions.

Enhanced “Show Fitting Deviation on Preview” Option 

The “Show Fitting Deviation on Preview” option has been improved to hide selections during the preview for better visibility. Users 

can also edit the Color Bar directly during the preview when using Constructed Geometry commands.



Oqton, Inc. 10

4	 FIXED BUGS

Note: The  /  labels indicate features that are also available in Geomagic Control X Essentials and Geomagic Control X 
Essentials Connect software packages.

Common
	y GV-28675: 

 
The application crashed when forcing a rebuild after opening a specific file.

	y GV-28126, 

GV-27807, 

GV-27806: 
 

Certain items in Preferences were improperly migrated from the previous versions during updates.

	y GV-27433: 
 

When customizing the Color Bar in the Edit Template window, the colors or context in the custom Color Bar are 

displayed incorrectly or disappeared in the Manage Colorbar Template window.
	y GV-27223: 

 
The context menu did not appear when right-clicking on the Color Bar template in the Edit Template window.

	y GV-26293, 

GV-25877, 

GV-23238: 
 

Geomagic Control X took a long time to launch offline and also experienced delays when online due to a 

delayed license verification check.

Region Segmentation
	y GV-26992: 

 
The application crashed when clicking the Estimate button in the Mesh Roughness option in the Auto Segment 

command.

Constructed Geometry
	y GV-28055: 

 
The Color Bar still appeared when using methods that do not support the 'Show Fitting Deviation on Preview' 

option or when the option was disabled in supported methods in the Constructed Geometry Commands.

Compare Tools
	y GV-29225: Analysis results remained in the Tabular View even after 2D Twist Analysis was canceled.

	y GV-29009: 
 

Comparision results differed when saving a rebuilt file, reopening it, and rebuilding it again.

	y GV-28729: 
 

Comparison Point features in the revision file displayed errors after reopening and rebuilding.

	y GV-28612: Curve Deviation features in the revision file displayed errors after reopening and rebuilding.

	y GV-28125, 

GV-22013, 

GV-18428: 
 

Deviation results from the same location differed based on the Result Option in the 3D Compare command. 

Additionally, deviation results from 3D Compare at the same location were inconsistent with those from the 

Comparison Point.

	y GV-4682, 

GV-3458: 
 

Minimum and maximum deviation values in annotations generated by Automatic Local Average Tagging 

differed from the statistical values displayed in 3D Compare’s tabular view.

Visual Script
	y GV-28753: Running 3D Compare in Visual Script produced different results compared to those in the application.

	y GV-26512:
The connection between Geomagic Control X and the Visual Script Editor broke after approximately 10 minutes 

if a single Visual Script action exceeded this duration.
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Automation
	y GV-28341, 

GV-26779:

The Inspection Result window on the server displayed “OK” even when the inspection project included features 

with no results.
	y GV-25764, 

GV-24896:

The Automation Client became unresponsive when the Monitoring folder was empty, and a large file was 

written directly from a scanner application.

	y GV-23280:
Geomagic Control X for ScanTech crashed during batch processing when a predefined scan process was 

selected as the target result.

File I/O
	y GV-28458: 

 
Importing a specific STP (STEP) file caused the application to crash.

	y GV-28206: 
 

The Sampling Ratio option in the Import dialog did not work correctly for PTS (Geomagic Point) files.

Hardware Interface
	y GV-26607: 

The on-screen probe tip was displayed incorrectly when using the ScanTech Plug-in.

Report
	y GV-28023: 

 
Disclaimers on the cover page of report templates incorrectly referenced 3D Systems instead of Oqton.

Localization
	y GV-28343: 

 
Translation and layout issues occurred in the Japanese user interface.
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